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INTRODUCTION 
This program was developed by the Advanced Traffic Analysis Center (ATAC) to store, process, 
and analyze volume data from Autoscope traffic cameras.  Prior to using this tool, users must 
have Detector Volume Reports generated by Autoscope software having a .TXT extension.  
This tool was written in JAVA; therefore, a Java runtime environment must be installed on the 
computer.  

 

The purpose of this software is to process Autoscope volume data and display the information in 
an organized manner for traffic operation and transportation planning analyses.  A template was 
designed in Microsoft Excel to be used with Autoscope Solo Pro software (Network Brower).  
The template which was developed provides a summary sheet with daily averages in 15-minute 
intervals for the following information: 

 Approach turning movement volumes 
 Hourly intersection totals 
 Intersection daily total 

 

DEVELOPING AUTOSCOPE VOLUME DATA 
Having the proper setup with the Autoscope detector files is vital to the functionality of the 
Volume reader.  Without using the proper setup as follows, the reader will provide either 
inaccurate or no results at all. 
 

Autoscope Setup 
A few procedures must be performed within Autoscope regarding the detector and polling 
configuration.  The following sections describe these requirements in more detail.   It is 
assumed that the user has basic knowledge of correctly installing and setting up Autoscope 
detectors.  Substandard detector placement and setup can adversely affect the volume 
accuracy.  

 

Detector Configuration and Naming 
To use the template, the following procedures must be performed during the detector setup: 

1. Open the Autoscope Detector Editor for the desired Autoscope MVP. 

2. Insert a speed detector in the desired lane by selecting the         icon.  

3. Insert a station detector with the        icon. 

a. Right click on the detector and select Add/Remove Members. 

b. Attach the speed detector (not the count detector) to the station detector. 

c. After completing the previous steps the detector setup should look similar to   Figure 1 
when the detector station is selected. 
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d. Configure the parameters of the station detector by double clicking on the station 
detector (Figure 2). 

e. Since the template extracts data from the Autoscope output files, care must be used 
when naming the detection stations. The following naming strategy is recommended. 

 The detector title should include the direction, lane number and the turning 
movement, e.g., NB_1_T.  (Note: The maximum number of detectors is eight per 
approach). 

 Turning movement must be last and only use the first letter of the movement, i.e., L, 
T, and R. This is how the template organizes the Autoscope data. Inaccurate output 
will be produced if this naming convention is not followed. 

 Other naming patterns may be applied as long as the turning movement is the last 
character and each detector name is unique. 

 

 

 

 

 

 

 

 

 

 

 

f. Continue this process for each individual lane for which volume counts will be 
conducted. 

4. Once the speed and station detectors have been setup upload the detector file to the 
Autoscope MVP. 

 

 

 

Figure 1.  Autscope Detection Setup

Figure 2. Station Detector Setup
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Data Collection: Polling Setup 
To collect the volume data, a polling configuration will have to be setup. The configuration 
specifies the type of data and time intervals for data collection. 

1. With the Autoscope Network Browser open, select the appropriate Autoscope MVPs. 

2. Select Data Collector under the Data pull-down menu. 

 A dialog box will appear allowing you to download any data that is currently on the MVP 
before continuing setup for the new configuration. You may close this dialog box or 
download the data. (Keep in mind when setting up a new polling configuration previous 
polling data will be erased.) 

3. Select New under the File pull-down menu. Use the same Autoscope MVPs if a dialog box 
asks. The polling dialog box will appear as shown in Figure 3. 

a. In the Add Poll dialog box configure the following: 

i. Select the Autoscope MVPs which are to be used by holding the Ctrl key and clicking 
on the Autoscope descriptions. 

ii. Select the following parameters: 

1. Detector Type – Detector Stations   

2. Fields – Volume 

3. Interval Type – Data Interval 

4. Data Interval – 15 minutes 

b. Click Add Poll 

c. Close the dialog box 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

4. Check that Persistent is selected under the Polling pull-down menu. This will enable the 
MVPs to collect data without being connected to the computer. 

 

 

Figure 3. Polling Configuration 
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5. Select the View pull-down menu followed by Options. 

a. Under the Display tab select the following: Detector Title, Date, Time and Volume 
(Figure 4). 

b. Select the Data tab (Figure 5). 

i. Enable the automatic save option. 

ii. Select the desired base storage folder for storing the data. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

6. Click OK to apply the changes. 

7. Select the        icon to start polling data. 

 

Note:  It is allowable to select any of the boxes in the Display Options window between ‘Data 
Interval’ and ‘Volume’.  However, for the Autoscope Intersection Volume Reader to correctly 
read the volume data, the first 9 options along with the ‘Volume’ option MUST be checked. 

 

Data Collection: Downloading Data 
After polling data for the desired amount of time, the data can be downloaded for reviewing and 
processing. Be aware of the length of time the MVP’s memory will last. Once the memory has 
been filled, the MVP will overwrite the oldest data in the list. (The time length is dependant on 
the amount of detectors which are being polled.) 

 

From the Autoscope network browser: 

1. Highlight Autoscope MVPs for the intended intersection. 

2. Select Data followed by Data collector. 

3. Select a Time Stamp or download all the Persistent Poll Data from the dialog box. 

 (Keep in mind when selecting times that interval end times are used in Autoscope.) 

Figure 4. Display Options Figure 5. Data Options 
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 After the download is complete it will be displayed in the Data Collector window. The 
data is also saved in the selected base storage folder. 

 

PROCESSING/STORING AUTOSCOPE DATA 
Once the Autoscope data is downloaded, it can be processed and stored using the Autoscope 
Intersection Volume Reader.  Using this program, Autoscope data is stored into Microsoft 
Access Databases.  Typically each intersection would have its own database, with the ability to 
periodically update and add new traffic counts.  The time it takes for the reader to place the 
counts in the database is dependent on the size of the .txt file.  Multiple Volume Reader 
applications can operate at the same time; however, the time for completion will be increased in 
accordance of how many applications are being used. 
1. Open the “Autoscope Volume Reader.JAR” file (Figure 6).   

 From the main screen (Figure 6), users can initially select “Import .TXT file” or “Select 
.MDB file”.  The “Select .MDB File” can be used if the data has previously been loaded 
into the intersection database (see Step #12).   

 

 
Figure 6.  Initial Autoscope Intersection Volume Reader screen. 
 
1. Type in the direction or name of the approach in the “Name” field under “Approach1” 
2. Select the “Import .TXT File” button. 
3. Browse to the appropriate .TXT file containing a Detector Volume Report created by the 

Autoscope software. 
4. Enter a database name (.MDB file), which should correspond to the intersection name and 

approach direction, and select Save.   
 The program will read the relevant data from the .TXT file and write the relevant data 

into the .MDB file.  This process can take several minutes and is dependent upon how 
much data is stored in the .TXT file.  
 

Note:  The reading, checking, parsing, and writing the Autoscope data is very computational 
intensive.  Although a status display is not available, the program is processing the data 
(check the directory where the database file is stored to see the file size grow).  Processing 
time as high as 30 minutes has been experienced when converting a 13 MB Autoscope 
output file (113 days of data with 6 detector stations equating to 65,496 rows of data). 
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5. Repeat Steps 2-5 for each approach in the intersection.  
 See Figure 7 with completed approach configuration 

 

 
Figure 7.  Reader screen after approach configuration. 
 
Analysis Duration/Days  
6. Based on the data collection dates contained in the .TXT file, select the appropriate Start 

Date and End Date by selecting the calendar button (Figure 8).  
 If the start and end dates are the same, only data for the specific day will be analyzed.   

7. Select the appropriate day(s) of the week to analyze. 
 Users can analyze Weekdays, Weekends, All, or Select Day(s).  
 If Select Day(s) is active, any combination of the days of the week may be selected for 

analysis.   
 

 
Figure 8.  Analysis duration and days of the week. 
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Processing Volume Data 
8. Select the “Submit” button to process the detector volume data.   

 Once this is performed, a “Results” window will be generated showing the traffic volume 
data (Figure 9). 

 The 1st column shows the start time of the row of data.   
 The preceding column headings show the intersection turning movements based on the 

user input (labeled the same order as approaches specified earlier, as well as by 
movement Left, Thru, and Right.  Total columns are illustrated for each approach, as well 
as the total intersection.  

 If an approach or movement is not used, it is simply not displayed.   
 If more than one day of data were selected, the cell values represent the average for that 

time interval and the selected day(s) of the week.   
 If communication were lost to the controller causing gaps in the recorded data, the 

averages would be based on the available data. 
 

 
Figure 9. Processed data in Result Window. 
 
9. Print the displayed information using the File menu pull-down.  Once “Print” is selected, a 

dialog box (Figure 10) will be displayed for entering the intersection name.  Next, select the 
desired printer for printing the results. 
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Figure 10.  Intersection Name dialog box 

 
10. To graph or perform statistical analyses with the data, select (left mouse click) the 0:00 AM 

interval.  While holding down the left mouse button, drag the mouse cursor to the bottom 
right interval so all of the data are highlighted.  Using the keyboard press and hold the “Ctrl” 
key while selecting the letter “c”.  This will copy the data to the computer’s memory.  Open 
Excel (or equivalent) and paste the data (press and hold the “Ctrl” key while selecting the 
letter “v”). 
 The user can select portions or all of the data to copy and paste into a spreadsheet 

program. 
 

DATABASE INFORMATION 
 If users have previously imported a .TXT file and wish to perform additional analyses with 

the data, select “Select .MDB file”. 
 Browse to the appropriate .MDB file that was previously created by the Autoscope 

Intersection Volume Reader program. 
 
NOTE:  The database (.MDB) file should correlate to the intersection name.  Additional 
volume information from the .TXT files is added to the current .MDB file.  Only new volume 
data (based on the Date/Time field) will be added to the .MDB file and overlapping data will 
be disregarded.   
 

SYSTEM REQUIREMENTS 
 Autoscope Network Browser 
 J2SE (Java 2, Standard Edition) Runtime Environment can be downloaded free of charge 

from http://java.sun.com. 
 
 

PROGRAMMED BY:  KIRAN KATTAKINDI  
 

 

Updated:  October 14, 2008 


